Opened 4 years ago

Closed 4 years ago

#5879 closed defect (fixed)

Flash is drawn on top of window title

Reported by: Joonas Lehtinen Owned by: Matti Tahvonen
Priority: minor Milestone: Vaadin 6.5.0.pre2
Component: Component - client side Version: 6.4.6
Keywords: Cc: jouni.koivuviita@…
Depends on:
Workaround:
Verified:

Description (last modified by Matti Tahvonen)

See http://vaadin.com/forum/-/message_boards/message/238452

On FF3.6/Windows 7 flash is drawn on top of window title. Test with sampler flash example. See screenshot

On IE/Windows 7 the whole window gets covered by the window.

Attachments (1)

2mi25g4.jpg (141.6 KB) - added by Joonas Lehtinen 4 years ago.

Download all attachments as: .zip

Change History (13)

Changed 4 years ago by Joonas Lehtinen

comment:1 Changed 4 years ago by Artur Signell

  • Component changed from undefined to Component - client side
  • Milestone set to Vaadin 6.4.8

comment:2 Changed 4 years ago by Henri Sara

Probably the same issue with embedded PDF viewer: see http://vaadin.com/forum/-/message_boards/message/267197 .

comment:3 Changed 4 years ago by Artur Signell

  • Milestone changed from Vaadin 6.4.9 to Vaadin 6.5.0

comment:4 Changed 4 years ago by Matti Tahvonen

  • Owner changed from ticketmaster to Matti Tahvonen
  • Priority changed from major to minor
  • Status changed from new to accepted

I think this is not a regression. Also the infamous flash workaround (wmode = transparent) works fine on those test machines I could try, lowering priority.

comment:5 Changed 4 years ago by Matti Tahvonen

PDF issue split to #6219

comment:6 Changed 4 years ago by Matti Tahvonen

fix in [16739] and finetuning in [16740]. Sets the wmode to transparent by default if flash type is set. Can be overridden (must be because of performance hit).

comment:7 Changed 4 years ago by Matti Tahvonen

  • Cc jouni.koivuviita@… added

An other fix (but probably not applicable to all themes) in [16741]. Figured this out when spending some time with the PDF issue. The magic lies in having a solid base color as background instead of transparent. Eg. sampler flash demo with base theme has no issues.

http://demo.vaadin.com/sampler/?theme=base#FlashEmbed

comment:8 Changed 4 years ago by Matti Tahvonen

  • Description modified (diff)

most common cases now covered.

Might still be an issue if flash not embedded with Embedded component and IE or non default theme ( runo or liferay) is used. Won't fight with this further now.

comment:9 Changed 4 years ago by Matti Tahvonen

  • Resolution set to fixed
  • Status changed from accepted to closed

review by john

comment:10 Changed 4 years ago by Jonatan Kronqvist

  • Milestone changed from Vaadin 6.5.0.pre2 to Vaadin 6.5.2
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:11 Changed 4 years ago by Matti Tahvonen

  • Milestone changed from Vaadin 6.5.2 to Vaadin 6.5.0.pre2
  • Resolution set to fixed
  • Status changed from reopened to closed

innocent until proven guilty

comment:12 Changed 4 months ago by Artur Signell

  • Fv unset
Note: See TracTickets for help on using tickets.