Opened 2 years ago

Closed 2 years ago

#9454 closed defect (duplicate)

Scrollbars in ie8, ie9 and maximum rows in table

Reported by: ogaerick Owned by: ticketmaster
Priority: blocker Milestone:
Component: Component Version: 6.8.2
Keywords: table scrollbars ie8 ie9 Cc:
Depends on:
Workaround:
Verified:
Fv: no

Description

I have a table that uses lazy loading. There are over 400,000 records in the table. In IE8 and IE9 the scrollbar seizes to 84530 rows. If I scroll doen all the way, the scrollbar changes to aprox 120000 rows.
When I scroll down again, no data is shown after 84530 rows (ie shows empty table).
In chrome, safari and firefox the scrollbar is shown correctly, whenn I scroll down all the way it will correctly show the last entries of the 400,000 records.

Attachments (1)

IE9-table-problem.zip (604.0 KB) - added by ogaerick 2 years ago.
Screen shots

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by ogaerick

Screen shots

comment:1 Changed 2 years ago by Johannes Dahlstrom

Sounds like an inherent browser limitation; we may not be able to do anything about it.

comment:2 Changed 2 years ago by Artur Signell

  • Resolution set to duplicate
  • Status changed from new to closed

The issue is described in #4220 and relates to browser limitations on DIV sizes (and to how what the Table DOM structure looks like). This is also described in the Table javadocs and cannot be fixed without rewriting Table (see #7850).

comment:3 Changed 5 months ago by Artur Signell

  • Fv unset
Note: See TracTickets for help on using tickets.