Opened 5 years ago

Last modified 4 years ago

#11132 released defect (fixed)

AbstractSelect constructor calling nonfinal function, causing NullPointerException with Tree

Reported by: Sami Viitanen Owned by: John Ahlroos
Priority: blocker Milestone: Vaadin 7.0.2
Component: Component Version: 7.0-trunk
Keywords: Cc:
Depends on:
Workaround:
Verified:
Fv: no Pro Account: Mark as Priority

Description

With current Vaadin7 SNAPSHOT the AbstractSelect constructor is calling non-final function overridden by Tree class and calling it's uninitialized field (HashMap called "expanded"). Stack trace:

2013-02-25 10:53:07.552:WARN:oejs.ServletHandler:/com.vaadin.addon.touchkit.itest.TreeTest
java.lang.NullPointerException
	at com.vaadin.ui.Tree.cleanupExpandedItems(Tree.java:1691)
	at com.vaadin.ui.Tree.setContainerDataSource(Tree.java:850)
	at com.vaadin.ui.AbstractSelect.<init>(AbstractSelect.java:298)
	at com.vaadin.ui.Tree.<init>(Tree.java:163)
	at com.vaadin.ui.Tree.<init>(Tree.java:153)
	at com.vaadin.ui.Tree.<init>(Tree.java:144)
	at com.vaadin.addon.touchkit.itest.TreeTest.<init>(TreeTest.java:19)

Null check needed or proper fix would be to not call nonfinal functions.

Change history (5)

comment:1 Changed 5 years ago by Matti Tahvonen

Regression since fix to #11053

comment:2 Changed 5 years ago by John Ahlroos

  • Component changed from undefined to Component
  • Owner changed from ticketmaster to John Ahlroos
  • Priority changed from undefined to blocker
  • Status changed from new to accepted

comment:3 Changed 5 years ago by John Ahlroos

  • Resolution set to fixed
  • Status changed from accepted to closed

Reviewed by Leif Åstrand.

comment:4 Changed 4 years ago by Artur Signell

  • Fv unset

comment:5 Changed 4 years ago by Artur Signell

  • Status changed from closed to released
Note: See TracTickets for help on using tickets.