Opened 9 years ago

Last modified 3 years ago

#2871 released task (fixed)

Support other GWT versions than 1.5.3

Reported by: Artur Signell Owned by: Henri Sara
Priority: blocker Milestone: Vaadin 6.0 pre
Component: dontuse-Plug-in for Eclipse (Use github.com/vaadin/eclipse-plugin instead) Version: 5.3.1
Keywords: Cc:
Depends on: #2870
Workaround:
Verified:
Fv: no

Description

#2553 adds support for downloading GWT libraries automatically but is limited to 1.5.3. #2870 adds information to the release jar about which gwt version it is compatible with. This information should be used in the plugin so the correct GWT version can be downloaded and used.

Change history (6)

comment:1 Changed 9 years ago by Artur Signell

  • Priority changed from minor to blocker

comment:2 Changed 9 years ago by Artur Signell

  • Milestone changed from Eclipse plugin backlog to Sprint 09/2009

comment:3 Changed 9 years ago by Henri Sara

  • Owner changed from ticketmaster to Henri Sara
  • Status changed from new to accepted

comment:4 Changed 9 years ago by Henri Sara

  • Resolution set to fixed
  • Status changed from accepted to closed

When changing the Vaadin version using the plugin, the correct GWT version is automatically downloaded and added to the project classpath (in [7778] that also addresses #2872 and #2873).

comment:5 Changed 4 years ago by Artur Signell

  • Fv unset

comment:6 Changed 3 years ago by Artur Signell

  • Status changed from closed to released
Note: See TracTickets for help on using tickets.