Opened 8 years ago

Last modified 3 years ago

#4118 released defect (fixed)

Authoring form fails to initialize for some add-ons

Reported by: Sami Ekblad Owned by: ticketmaster
Priority: blocker Milestone: Directory 1.0
Component: Directory Version:
Keywords: Cc:
Depends on:
Workaround: Save the authoring URL of the add-on in question. Log out and login back. Use the URL to edit the add-on again.
Verified:
Fv: no Pro Account: Mark as Priority

Description

In some situations the initialization of add-on form init fails due to a hibernate LazyInitializationException in highlights.

Ask help from Sami when fixing this.

Attachments (1)

ticket4118-stacktrace.txt (23.1 KB) - added by Teemu Pontelin 8 years ago.

Download all attachments as: .zip

Change history (11)

Changed 8 years ago by Teemu Pontelin

comment:1 Changed 8 years ago by Teemu Pontelin

Added related stacktrace as an attachment.

comment:2 Changed 8 years ago by Sami Ekblad

  • Workaround modified (diff)

comment:3 Changed 8 years ago by Sami Ekblad

Seems that this has nothing to do with the published/unpublished state of the add-on. You can find the exception happening in the Table using Firebug or similar tool, but it is not shown to the user.

comment:4 Changed 8 years ago by Henrik Paul

#4140 was a duplicate of this. That ticket contains a short video on duplicating the problem.

comment:5 Changed 8 years ago by Teemu Pontelin

  • Priority changed from normal to major

comment:6 Changed 8 years ago by Teemu Pontelin

  • Milestone changed from Directory backlog to Directory 1.0
  • Priority changed from major to blocker
  • Version 6.2.3 deleted

comment:7 Changed 8 years ago by Marc Englund

  • Summary changed from Selecting some (unpublished) add-on initialization of the add-on form fails. to Authoring form fails to initialize for some add-ons

comment:8 Changed 8 years ago by Marc Englund

  • Resolution set to fixed
  • Status changed from new to closed

Some lazyloading collection were not initialized properly, Addon now has a initialize() method - unfortunately it needs to be updated whenever new stuff is added, and is not automatically recursive.
Fixed in [11351]

comment:9 Changed 4 years ago by Artur Signell

  • Fv unset

comment:10 Changed 3 years ago by Artur Signell

  • Status changed from closed to released
Note: See TracTickets for help on using tickets.